icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons_061

LinPHA < 1.3.2 SQL Injection Vulnerability

Medium

Synopsis

The remote web server contains a PHP script that is prone to an SQL injection attack.

Description

The remote host is running LinPHA, a web photo gallery application written in PHP. The version of LinPHA installed on the remote host fails to sanitize input to the 'order' parameter of the 'new_images.php' script before using it in the 'setSql' function in 'include/img_view.class.php' in a database query. Regardless of PHP's 'magic_quotes_gpc' setting, an unauthenticated attacker may be able to exploit this issue to manipulate such queries, leading to disclosure of sensitive information, modification of data or attacks against the underlying database.

Solution

Upgrade to version 1.3.2 or later.