icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons_061

MD-Pro < 1.0.82 index.php topicid Parameter SQL Injection

Medium

Synopsis

The remote host is vulnerable to a SQL Injection attack.

Description

The remote host is running MD-Pro, an open-source blogging software. This version of MD-Pro is vulnerable to a flaw in the way that it parses user-supplied data. Specifically, failure to parse reserved SQL characters allows an attacker to inject SQL queries to the database. An attacker exploiting this flaw would only need the ability to post data to the affected web application. Successful exploitation would result in the attacker executing arbitrary SQL commands on the database server.

Solution

Upgrade to version 1.0.82 or higher.