icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons_061

IBM DB2 9.1 < 9.1 Fix Pack 2 Multiple Vulnerabilities

High

Synopsis

The remote IBM DB2 database server is affected by multiple vulnerabilities.

Description

According to its version, the installation of IBM DB2 9.1 on the remote host is reported to be vulnerable to a number of local flaws. The most serious of these flaws involves a local buffer overflow. An attacker exploiting these flaws would need local access to the DB2 server. Successful exploitation would result in the attacker executing arbitrary code.

Solution

Upgrade to IBM DB2 9.1 Fix Pack 2 or higher.