icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons_061

PostgreSQL SQL Injection

High

Synopsis

The remote host is vulnerable to a SQL Injection attack.

Description

The remote host is running PostgreSQL, an open source relational database. This version is vulnerable to a SQL Injection flaw when passed properly formatted SQL queries coupled with invalidly-encoded multibyte data. An attacker exploiting this flaw would need to be able to send queries to the PostgreSQL server. As such, this exploit typically requires authentication. Successful exploitation would result in the attacker executing arbitrary SQL commands on the database server.

Solution

Upgrade to version 7.3.15, 7.4.13, 8.0.8, 8.1.4, or higher.