icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons_061

Resin < 3.0.19 Directory Traversal and Path Disclosure Vulnerabilities

High

Synopsis

The remote host is vulnerable to multiple attack vectors.

Description

The remote web server is running Resin. Versions 3.0.17 and 3.0.18 are vulnerable to multiple flaws which impact Confidentiality. An attacker exploiting these flaws would be able to disclose physical paths and read files outside of the web server root directory. Reading of confidential files could lead to more sophisticated attacks.

Solution

Upgrade to version 3.0.19 or higher.