icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons_061

Owl Intranet Engine xrms_file_root Parameter Remote File Inclusion

High

Synopsis

The remote web server contains a PHP script that suffers from a remote file include vulnerability.

Description

The remote host is running Owl Intranet Engine, a web-based document management system written in PHP. The version of Owl Intranet Engine on the remote host fails to sanitize user-supplied input to the 'xrms_file_root' parameter of the 'lib/OWL_API.php' script before using it in a PHP 'require_once' function. An unauthenticated attacker may be able to exploit this issue to view arbitrary files on the remote host or to execute arbitrary PHP code, possibly taken from third-party hosts.

Solution

No solution is known at this time.