icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons_061

vBulletin < 3.5.4 HTML Injection

Medium

Synopsis

The remote host is vulnerable to an HTML Injection attack.

Description

The version of vBulletin installed on the remote host fails to properly sanitize user-supplied input. Given this, the application is prone to an HTML injection attack. An attacker exploiting this flaw would post a malicious entry to the vBulletin board. Unsuspecting users perusing the board would have code executed within their browser. Successful exploitation could lead to the theft of confidential data.

Solution

Upgrade to version 3.5.4 or higher.