icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons_061

phpWebThings download.php file Parameter SQL Injection

High

Synopsis

The remote host is vulnerable to a SQL Injection attack.

Description

The remote host is running phpWebThings, a PHP web development framework. This version of phpWebThings is vulnerable to a SQL Injection flaw. An attacker exploiting this flaw would send a malformed query to the download.php script. Successful exploitation would allow the attacker to execute commands on the backend SQL database. This can lead to loss of confidential materials as well as compromise of the integrity of the SQL database server.

Solution

No solution is known at this time.