icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons_061

PHPSysInfo < 2.4.0 Multiple Vulnerabilities

Medium

Synopsis

The remote host is vulnerable to multiple attack vectors.

Description

The remote host is running PHPSysInfo, a PHP application that gives system information via a web interface. This version of PHPSysInfo is vulnerable to a multitude of flaws. These flaws include Cross-Site Scripting (XSS), HTML injection, and a local file inclusion flaw. There is also an inherent risk whenever system information is displayed via a web interface. Of these flaws, the more serious flaw is the local file inclusion vulnerability. An attacker exploiting this flaw would be able to retrieve and display potentially confidential files (such as /etc/passwd). This can lead to confidential materials being downloaded by anonymous users.

Solution

Upgrade to version 2.4.0 or higher.