icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons_061

PHPList < 2.10.3 Multiple Vulnerabilities

Medium

Synopsis

The remote host is vulnerable to multiple attack vectors.

Description

The remote host is running PHPList. PHPList is a PHP application that gathers handles mailing and customer lists. This version is reported to be prone to a SQL Injection flaw. An attacker exploiting this flaw would be able to read the database, manipulate the database, and possibly run commands with the privileges of the web server. The SQL injection attack vector requires administrative access. There is also a directory traversal flaw where an attacker can send a malformed HTTP query and retrieve files outside of the webroot directories. Finally, the remote application is vulnerable to multiple HTML injection and Cross-Site Scripting (XSS) flaws.

Solution

Upgrade to version 2.10.3 or higher.