icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons_061

Acme thttpd < 2.24 CGI Test Script Symlink Arbitrary File Overwrite

Medium

Synopsis

The remote host is vulnerable to a local flaw in the way that it creates temporary files.

Description

The remote host is running a vulnerable version of Acme thttpd. It is reported that versions prior to 2.24 are prone to a local flaw where temporary files can be used by local users to escalate their privileges on the machine. Specifically, attackers can use the insecure temp files to overwrite critical web content or configuration files.

Solution

Upgrade to version 2.24 or higher.