icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons_061

phpPGAds/phpAdNew < 2.0.6 lib-view-direct.inc.php clientid Parameter SQL Injection

High

Synopsis

The remote web server contains a script that is vulnerable to a SQL injection attack.

Description

There is a flaw in the remote phpAdNew/phpPgAds PHP Ads server, a banner management and tracking system written in PHP. This version of phpAdNew is vulnerable to a SQL Injection vulnerability. An attacker exploiting this flaw would send a malformed HTTP request to the phpPgAds server. The server, failing to parse out special SQL characters, would give the attacker the ability to read or write database data as well as potentially execute code.

Solution

Upgrade to version 2.0.6 or higher.