icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons_061

JGS-Portal < 3.03 Multiple Scripts SQL Injection

High

Synopsis

The remote host is running JGS-Portal, a plugin for the Woltlab web application.

Description

The remote host is running JGS-Portal, a plugin for the Woltlab web application. This version of JGS-Portal is vulnerable to a remote SQL injection attack. An attacker exploiting this flaw would send a malformed HTTP query to one of the following PHP scripts: - jgs_portal.php - jgs_portal_statistik.php - jgs_portal_beitraggraf.php - jgs_portal_mitgraf.php - jgs_portal_themengraf.php - jgs_portal_viewsgraf.php

Successful exploitation would result in the attacker being able to read or write confidential data.

In addition, the attacker may be able to execute arbitrary code on the remote database server.

Solution

Upgrade to version 3.0.3 or higher.