icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons_061

PHPCoin < 1.2.2 2005-12-13 Multiple Script SQL Injection

High

Synopsis

The remote web server contains a script that is vulnerable to a SQL injection attack.

Description

The remote host is running phpCOIN version 1.2.2 or older. This version of PHPCoin is vulnerable to a remote SQL injection attack. This vulnerability is possible due to the login.php and mod.php scripts not properly parsing SQL reserved characters from the user-supplied input. An attacker exploiting these flaws would be able to gain access to confidential materials with both read and write access. In addition, the attacker may be able to execute arbitrary code on the remote database server.

Solution

Upgrade to phpCOIN 1.2.2 with at least fix-file 2005-12-13 or higher.