icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons_061

Woltlab Burning Board XSS / SQL Injection Vulnerabilities

Medium

Synopsis

The remote host is vulnerable to multiple attack vectors.

Description

The remote host is running Woltlab Burning Board, a web bulletin board written in PHP. This version of Burning Board is vulnerable to a remote Cross-Site Scripting (XSS) attack. An attacker exploiting this flaw would typically need to convince a user to browse to a malicious URI. Success exploitation would result in the theft of confidential materials (such as authentication cookies).

This version of Woltlab is also vulnerable to a remote SQL injection attack. An attacker exploiting this flaw would send a malformed 'email' form query to the 'verify_email()' function. Succesful exploitation would result in the attacker being able to read or write confidential data. In some instances, the attacker may be able to execute arbitrary code on the remote database server.

Solution

Upgrade or patch according to vendor recommendations.