icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons_061

Coppermine Gallery SQL Injection

High

Synopsis

The remote host is vulnerable to a SQL Injection attack.

Description

The remote host is running CopperMine Gallery, a set of PHP scripts to handle galleries of pictures. There is a flaw in this version of Coppermine Gallery. Specifically, the remote user's cookie is not properly parsed for SQL special characters. An attacker exploiting this flaw would send a malicious cookie to the Coppermine application. Successful exploitation would result in the attacker being able to read and write sensitive database data as well as potentially executing arbitrary code on the remote database.

Solution

Upgrade to Coppermine greater than 1.3.2.