icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons_061

PostNuke < 0.760 RC4 Multiple XSS and SQL Injection Vulnerabilities

High

Synopsis

The remote web server contains a script that is vulnerable to a SQL injection attack.

Description

The remote host is running PostNuke version 0.760 RC3 or older. This version of PostNuke is vulnerable to a remote Cross-Site Scripting (XSS) flaw. Specifically, failure to parse malicious input to the 'op' parameter of the user.php script or the 'module' parameter of the admin.php script can lead to the injection of script code. An attacker exploiting this flaw would need to be able to entice the victim into browsing a malicious URI. Successful exploitation would result in the attacker being able to inject arbitrary script code into the browser of the unsuspecting user. This can lead to disclosure of confidential information. In addition, the remote host is vulnerable to a remote SQL Injection attack. An attacker exploiting this flaw would be able to read/write confidential database data.

Solution

Upgrade to version 0.760 RC4 or higher.