icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons_061

YaBB < 2.1 YaBB.pl username Parameter XSS

Medium

Synopsis

The remote host is using the YaBB web forum software.

Description

The remote host is using the YaBB web forum software. This version of YaBB is vulnerable to a cross-site scripting (XSS) attack. Exploiting the XSS flaws may enable an attacker to inject arbitrary script code into the browser of unsuspecting users. A successful attack would potentially allow the attacker the ability to view confidential data (cookies, authentication data, and more.) or compromise the integrity of the local system via the web browser.

Solution

Upgrade to YaBB 2.1 or higher.