icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons_061

CopperExport Plugin < 0.2.1 xp_publish.php SQL Injection

High

Synopsis

The remote web server contains a script that is vulnerable to a SQL injection attack.

Description

The remote host is running CopperExport, a plug-in for Apple iPhoto and CopperMine that allows users to directly export images to a Coppermine gallery. An attacker exploiting this flaw would send a specially crafted HTTP request to the application. Upon parsing the request, the server would run commands embedded within the request. A successful attack would give the attacker the ability to view data, modify data, and potentially execute system commands with the permission of the web server. It should be noted that the vulnerability is in a CopperExport script that runs on a CopperMine server.

Solution

Upgrade to version 0.2.1 or higher.