icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons_061

Stadtaus Form Mail < 2.4 formmail.inc.php Remote File Inclusion

Medium

Synopsis

The remote host is vulnerable to an arbitrary 'command insertion' flaw.

Description

The remote host is running the Stadtaus PHP Form Mail script. This script is used to send form information to an email address. This version of Form Mail is vulnerable to a flaw where incorrect parsing of the script_root parameter of the formmail.inc.php script can lead to arbitrary code being sent to the 'include()' function call. A successful attack would give the attacker the ability to execute arbitrary code on the target server.

Solution

Upgrade to Form Mail 2.4 or higher.