icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons_061

Icecast Server < 2.0.0 list_directory Function Traversal Directory Enumeration

Medium

Synopsis

The remote host is vulnerable to a directory traversal flaw.

Description

The remote host is running a vulnerable version of Icecast, an open-source streaming server. It is reported that every version prior 2.0.0 is vulnerable to directory traversal issue. This issue discloses the existence of directory on the remote system that may permit an attacker to gather information about the host.

Solution

Upgrade to Icecast 2.0.0 or higher.