icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons_061

thttpd < 2.20 Arbitrary World-Readable File Disclosure

Medium

Synopsis

The remote host is vulnerable to a flaw that allows attackers to retrieve sensitive files or data

Description

The remote host is running a vulnerable version of Acme thttpd. This web server includes a CGI program to provide server-side-includes functionalities. It is reported that this CGI program does not properly filter certain escape sequences. An attacker may view arbitrary files in a known location on the web server.

Solution

Upgrade to thttpd 2.20 or higher.