icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons_061

XChat Client URL Metacharacter Command Execution

Medium

Synopsis

The remote host is vulnerable to an flaw which allows attackers to execute arbitrary commands.

Description

The remote host is running the XChat IRC client. XChat IRC client versions 1.3.9 and later could allow an attacker to execute arbitrary shell commands. By embedding commands enclosed in backticks in URLs sent to XChat, a remote attacker can execute commands as the user.

Solution

Upgrade or patch according to vendor recommendations.