icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons_061

Neon < 0.24.7 WebDAV Client Library Unspecified Vulnerability

High

Synopsis

The remote host is missing a critical security patch or upgrade.

Description

The remote host is using software based on a vulnerable version of the Neon Library, an open-source HTTP and WebDAV client library. It is reported that versions prior 0.24.7 contains an unspecified vulnerability. Due to the nature of the library, it is likely that this is a remotely exploitable vulnerability.

Solution

Upgrade to Neon library 0.24.7 or higher.