Debian DSA-2940-1 : libstruts1.2-java - security update

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote Debian host is missing a security-related update.

Description :

It was discovered that missing access checks in the Struts ActionForm
object could result in the execution of arbitrary code.

See also :

http://www.debian.org/security/2014/dsa-2940

Solution :

Upgrade the libstruts1.2-java packages.

For the stable distribution (wheezy), this problem has been fixed in
version 1.2.9-5+deb7u1.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 6.5
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Debian Local Security Checks

Nessus Plugin ID: 77306 ()

Bugtraq ID: 67121

CVE ID: CVE-2014-0114