Flash Player for Mac <= 14.0.0.145 Multiple Vulnerabilities (APSB14-18)

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote Mac OS X host has a browser plugin that is affected by
multiple vulnerabilities.

Description :

According to its version, the instance of Flash Player installed on
the remote Mac OS X host is equal or prior to 14.0.0.145. It is,
therefore, affected by the following vulnerabilities :

- A use-after-free error exists that allows code
execution. (CVE-2014-0538)

- An unspecified security bypass error exists.
(CVE-2014-0541)

- Multiple errors exist related to memory leaks that can
be used to bypass memory address randomization.
(CVE-2014-0540, CVE-2014-0542, CVE-2014-0543,
CVE-2014-0544, CVE-2014-0545)

See also :

http://helpx.adobe.com/security/products/flash-player/apsb14-18.html
http://www.nessus.org/u?0cb17c10

Solution :

Upgrade to Adobe Flash Player version 14.0.0.176 or later.

Alternatively, Adobe has made version 13.0.0.241 available for those
installs that cannot be upgraded to 14.x.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true