LibreOffice < 4.2.5 Unspecified Macro Code Execution (Mac OS X)

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote host contains an application that is affected by a
vulnerability that allows unspecified VBA macro execution.

Description :

A version of LibreOffice is installed on the remote Mac OS X host that
is between versions 4.1.4 and 4.2.4. It is, therefore, affected by a
vulnerability that allows the execution of unspecified VBA macros
automatically.

Note that Nessus has not attempted to exploit this issue, but has
instead relied only on the application's self-reported version number.

See also :

http://www.libreoffice.org/about-us/security/advisories/CVE-2014-0247

Solution :

Upgrade to LibreOffice version 4.2.5 or later.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.7
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: MacOS X Local Security Checks

Nessus Plugin ID: 76595 ()

Bugtraq ID: 68151

CVE ID: CVE-2014-0247