Splunk Enterprise 4.3.x or < 5.0.9 / 6.0.5 / 6.1.2 Multiple OpenSSL Vulnerabilities

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

An application on the remote host is affected by multiple
OpenSSL-related vulnerabilities.

Description :

According to its version number, the remote Splunk Enterprise install
is 4.3.x or prior to 5.0.9, 6.0.5, or 6.1.2. It is, therefore,
affected by multiple OpenSSL-related vulnerabilities :

- An unspecified error exists that could allow an
attacker to cause usage of weak keying material
leading to simplified man-in-the-middle attacks.
(CVE-2014-0224)

- An unspecified error exists related to anonymous ECDH
cipher suites that could allow denial of service
attacks. Note this issue only affects OpenSSL TLS
clients. (CVE-2014-3470)

Note that Nessus has not tested for these issues but has instead
relied only on the application's self-reported version number.

See also :

http://www.splunk.com/view/SP-CAAAM2D
http://www.nessus.org/u?aacb6e20
http://www.openssl.org/news/secadv_20140605.txt

Solution :

Upgrade to Splunk Enterprise 5.0.9 / 6.0.5 / 6.1.2 or later as
appropriate.

Risk factor :

Medium / CVSS Base Score : 6.8
(CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 5.9
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 76528 ()

Bugtraq ID: 67898
67899

CVE ID: CVE-2014-0224
CVE-2014-3470