Apache mod_wsgi < 3.5 Apache Process Privilege Escalation

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote web server module is affected by a privilege escalation
vulnerability.

Description :

According to the web server banner, the version of mod_wsgi running on
the remote host is prior to version 3.5. It is, therefore, affected by
a privilege escalation vulnerability.

The issue occurs due to the improper handling of error codes returned
by 'setuid'. This flaw allows local attackers to manipulate the number
of processes that are run by the user to affect the outcome of
'setuid' during the forking of daemon mode processes. This could allow
the attacker to gain elevated privileges.

Note that Nessus has not tested for these issues but has instead
relied only on the application's self-reported version number.

See also :

http://www.nessus.org/u?b35a2a41

Solution :

Upgrade to mod_wsgi 3.5 or later.

Risk factor :

Medium / CVSS Base Score : 6.2
(CVSS2#AV:L/AC:H/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 5.4
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 76497 ()

Bugtraq ID: 67532

CVE ID: CVE-2014-0240