Adobe AIR for Mac <= 14.0.0.110 Multiple Vulnerabilities (APSB14-17)

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote Mac OS X host contains a version of Adobe AIR that is
affected by multiple vulnerabilities.

Description :

According to its version, the instance of Adobe AIR on the remote Mac
OS X host is equal or prior to 14.0.0.110. It is, therefore, affected
by the following vulnerabilities :

- A CSRF bypassing Same Origin Policy vulnerability
exists that could leak potentially sensitive data.
(CVE-2014-4671)

- Multiple unspecified errors exist that could allow
unspecified security bypass attacks. (CVE-2014-0537,
CVE-2014-0539)

See also :

http://helpx.adobe.com/security/products/flash-player/apsb14-17.html

Solution :

Upgrade to Adobe AIR 14.0.0.137 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: MacOS X Local Security Checks

Nessus Plugin ID: 76414 ()

Bugtraq ID: 68454
68455
68457

CVE ID: CVE-2014-0537
CVE-2014-0539
CVE-2014-4671