HylaFAX+ 5.2.4 < 5.5.4 Remote Buffer Overflow

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote host contains an application that is affected by a
heap-based remote buffer overflow vulnerability.

Description :

According to its version number, the HylaFAX+ install hosted on the
remote web server is 5.2.4 or later and prior to 5.5.4. It is,
therefore, affected by a heap-based remote buffer overflow
vulnerability.

The flaw exists when 'hfaxd' is compiled with support for LDAP. The
user input for LDAP authentication is not properly validated. This
could allow a remote attacker to cause a denial of service or execute
arbitrary code.

Note that Nessus has not tested for this issues, but has instead
relied only on the application's self-reported version number.

See also :

http://hylafax.sourceforge.net/news/5.5.4.php
http://seclists.org/bugtraq/2013/Sep/148

Solution :

Upgrade to version 5.5.4 or later.

Risk factor :

Medium / CVSS Base Score : 6.8
(CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 5.3
(CVSS2#E:POC/RL:OF/RC:C)
Public Exploit Available : true

Family: Misc.

Nessus Plugin ID: 76348 ()

Bugtraq ID: 62729

CVE ID: CVE-2013-5680