IBM DB2 9.7 < Fix Pack 9a Multiple Vulnerabilities

This script is Copyright (C) 2014-2015 Tenable Network Security, Inc.


Synopsis :

The remote database server is affected by multiple vulnerabilities.

Description :

According to its version, the installation of DB2 9.7 running on the
remote host is prior to Fix Pack 9a. It is, therefore, affected by one
or more of the following vulnerabilities :

- An unspecified error exists related to handling
malformed certificate chains that allows denial
of service attacks. (CVE-2013-6747)

- A build error exists related to libraries in insecure
locations that allows a local user to carry out
privilege escalation attacks. Note that this issue does
not affect the application when running on Microsoft
Windows operating systems. (CVE-2014-0907)

- An unspecified error exists related to the TLS
implementation that allows certain error cases to cause
100% CPU utilization. (CVE-2014-0963)

See also :

http://www-01.ibm.com/support/docview.wss?uid=swg21672100
http://www-01.ibm.com/support/docview.wss?uid=swg21671732
http://www-01.ibm.com/support/docview.wss?uid=swg21450666#9a
http://www-01.ibm.com/support/docview.wss?uid=swg24037559

Solution :

Apply IBM DB2 version 9.7 Fix Pack 9a or later.

Alternatively, in the case of DB2 Version 9.7 Fix Pack 8, contact the
vendor to obtain a special build with the interim fix.

Note that the vendor has posted a workaround for the build error issue
(CVE-2014-0907) involving the command 'sqllib/bin/db2chglibpath'.
Please consult the advisory for detailed instructions.

Risk factor :

High / CVSS Base Score : 7.1
(CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:C)
CVSS Temporal Score : 6.2
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: Databases

Nessus Plugin ID: 76114 ()

Bugtraq ID: 65156
67238
67616
67617

CVE ID: CVE-2013-6744
CVE-2013-6747
CVE-2014-0907
CVE-2014-0963