IBM DB2 9.5 <= Fix Pack 9 or 10 Multiple Vulnerabilities

This script is Copyright (C) 2014-2015 Tenable Network Security, Inc.

Synopsis :

The remote database server is affected by multiple vulnerabilities.

Description :

According to its version, the installation of IBM DB2 9.5 running on
the remote host is prior or equal to Fix Pack 9 or 10. It is,
therefore, reportedly affected by one or more of the following
vulnerabilities :

- An unspecified error exists related to handling
malformed certificate chains that could allow denial
of service attacks. (CVE-2013-6747)

- A build error exists related to libraries in insecure
locations that could allow a local user to carry out
privilege escalation attacks. Note this issue does not
affect the application when running on Microsoft
Windows operating systems. (CVE-2014-0907)

- An unspecified error exists related to the TLS
implementation that could allow certain error cases to
cause 100% CPU utilization. (CVE-2014-0963)

See also :

Solution :

Contact the vendor to obtain a special build with the interim fix.

Note that the vendor has posted a workaround for the build error issue
(CVE-2014-0907) involving the command 'sqllib/bin/db2chglibpath'.
Please consult the advisory for detailed instructions.

Risk factor :

High / CVSS Base Score : 7.1
CVSS Temporal Score : 6.2
Public Exploit Available : false

Family: Databases

Nessus Plugin ID: 76113 ()

Bugtraq ID: 65156

CVE ID: CVE-2013-6747