Flash Player for Mac <= 13.0.0.214 Multiple Vulnerabilities (APSB14-16)

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote Windows host has a browser plugin that is potentially
affected by multiple vulnerabilities.

Description :

According to its version, the instance of Flash Player installed on
the remote Mac OS X host is equal or prior to 13.0.0.214. It is,
therefore, affected by the following vulnerabilities :

- Multiple, unspecified errors exist that could allow
cross-site scripting attacks. (CVE-2014-0531,
CVE-2014-0532, CVE-2014-0533)

- Multiple, unspecified errors exist that could allow
unspecified security bypass attacks. (CVE-2014-0534,
CVE-2014-0535)

- An unspecified memory corruption issue exists that
could allow arbitrary code execution. (CVE-2014-0536)

See also :

http://helpx.adobe.com/security/products/flash-player/apsb14-16.html
http://www.nessus.org/u?0cb17c10

Solution :

Upgrade to Adobe Flash Player version 14.0.0.125 or later.

Alternatively, Adobe has made version 13.0.0.223 available for those
installs that cannot be upgraded to 14.x.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: MacOS X Local Security Checks

Nessus Plugin ID: 74433 ()

Bugtraq ID: 67961
67962
67963
67970
67973
67974

CVE ID: CVE-2014-0531
CVE-2014-0532
CVE-2014-0533
CVE-2014-0534
CVE-2014-0535
CVE-2014-0536