Apache Tomcat 8.0.x < 8.0.4 Multiple Vulnerabilities

This script is Copyright (C) 2014-2016 Tenable Network Security, Inc.


Synopsis :

The remote Apache Tomcat server is affected by multiple
vulnerabilities.

Description :

According to its self-reported version number, the instance of Apache
Tomcat 8.0.x listening on the remote host is prior to 8.0.4. It is,
therefore, affected by the following vulnerabilities :

- An error exists related to chunk size and chunked
requests that allow denial of service attacks.
(CVE-2014-0075)

- An error exists related to content length header
handling and Apache JServ Protocol (AJP) requests that
allow denial of service attacks. (CVE-2014-0095)

- An error exists related to XSLT handling and security
managers that allow a security bypass related to
external XML entities. (CVE-2014-0096)

- An error exists related to content length header
handling and using the application behind a reverse
proxy that could allow security bypass. (CVE-2014-0099)

Note that Nessus has not tested for these issues but has instead
relied only on the application's self-reported version number.

See also :

http://tomcat.apache.org/security-8.html#Fixed_in_Apache_Tomcat_8.0.5

Solution :

Upgrade to Apache Tomcat version 8.0.5 or later.

Note that while version 8.0.4 fixes these issues, that version was not
officially released, and the vendor recommends upgrading to 8.0.5 or
later.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)
CVSS Temporal Score : 4.3
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: Web Servers

Nessus Plugin ID: 74248 ()

Bugtraq ID: 67667
67668
67671
67673

CVE ID: CVE-2014-0075
CVE-2014-0095
CVE-2014-0096
CVE-2014-0099