Google Chrome < 35.0.1916.114 Multiple Vulnerabilities (Mac OS X)

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote Mac OS X host contains a web browser that is affected by
multiple vulnerabilities.

Description :

The version of Google Chrome installed on the remote Mac OS X host is
a version prior to 35.0.1916.114. It is, therefore, affected by the
following vulnerabilities :

- Use-after-free errors exist related to 'styles' and
'SVG' handling. (CVE-2014-1743, CVE-2014-1745)

- An integer overflow error exists related to audio
handling. (CVE-2014-1744)

- An out-of-bounds read error exists related to media
filters. (CVE-2014-1746)

- A user-input validation error exists related to
handling local MHTML files. (CVE-2014-1747)

- An unspecified error exists related to the scrollbar
that could allow UI spoofing. (CVE-2014-1748)

- Various unspecified errors. (CVE-2014-1749)

- An integer underflow error exists related to the V8
JavaScript engine. (CVE-2014-3152)

- An error exists related to the 'Blink' 'SpeechInput'
feature that could allow click-jacking and information
disclosure. (CVE-2014-3803)

Note that Nessus has not tested for these issues but has instead
relied only on the application's self-reported version number.

See also :

http://www.nessus.org/u?2da726ba

Solution :

Upgrade to Google Chrome 35.0.1916.114 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: MacOS X Local Security Checks

Nessus Plugin ID: 74123 ()

Bugtraq ID: 67517
67582

CVE ID: CVE-2014-1743
CVE-2014-1744
CVE-2014-1745
CVE-2014-1746
CVE-2014-1747
CVE-2014-1748
CVE-2014-1749
CVE-2014-3152
CVE-2014-3803