ESXi 5.5 < Build 1746974 / 5.5 Update 1 < Build 1746018 OpenSSL Library Multiple Vulnerabilities (remote check) (Heartbleed)

This script is (C) 2014-2015 Tenable Network Security, Inc.

Synopsis :

The remote VMware ESXi 5.5 host is potentially affected by multiple

Description :

The remote VMware ESXi host is 5.5 prior to build 1746974 or 5.5
Update 1 prior to build 1746018. It is, therefore, potentially
affected by the following vulnerabilities in the OpenSSL library :

- An error exists related to the implementation of the
Elliptic Curve Digital Signature Algorithm (ECDSA) that
could allow nonce disclosure via the 'FLUSH+RELOAD'
cache side-channel attack. (CVE-2014-0076)

- An out-of-bounds read error, known as the 'Heartbleed
Bug', exists related to handling TLS heartbeat
extensions that could allow an attacker to obtain
sensitive information such as primary key material,
secondary key material, and other protected content.

See also :

Solution :

Apply patch ESXi550-201404420 for ESXi 5.5 or ESXi550-201404401 for
ESXi 5.5 Update 1.

Risk factor :

High / CVSS Base Score : 9.4
CVSS Temporal Score : 8.2
Public Exploit Available : true

Family: Misc.

Nessus Plugin ID: 73917 ()

Bugtraq ID: 66363

CVE ID: CVE-2014-0076