VMSA-2014-0004 : VMware product updates address OpenSSL security vulnerabilities

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote VMware ESXi host is missing one or more security-related
patches.

Description :

a. Information Disclosure vulnerability in OpenSSL third-party library

The OpenSSL library is updated to version openssl-1.0.1g to
resolve multiple security issues.

The Common Vulnerabilities and Exposures project (cve.mitre.org) has
assigned the names CVE-2014-0076 and CVE-2014-0160 to these issues.

CVE-2014-0160 is known as the Heartbleed issue. More information
on this issue may be found in the reference section.

To remediate the issue for products that have updated versions or
patches available, perform these steps:

* Deploy the VMware product update or product patches
* Replace certificates per the product-specific documentation
* Reset passwords per the product-specific documentation

Section 4 lists product-specific references to installation
instructions and certificate management documentation.

See also :

http://lists.vmware.com/pipermail/security-announce/2014/000244.html

Solution :

Apply the missing patches.

Risk factor :

High / CVSS Base Score : 9.4
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:N)
CVSS Temporal Score : 8.2
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: VMware ESX Local Security Checks

Nessus Plugin ID: 73851 ()

Bugtraq ID: 66690

CVE ID: CVE-2014-0076
CVE-2014-0160