Apache Struts2 ClassLoader Manipulation Incomplete Fix for Security Bypass

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote web server contains a web application that uses a Java
framework that is affected by a security bypass vulnerability.

Description :

The remote web application appears to use Struts2, a web framework
that utilizes OGNL (Object-Graph Navigation Language) as an expression
language. The version of Struts2 in use is affected by a security
bypass vulnerability, possibly due to an incomplete fix for ClassLoader
manipulation implemented in version 2.3.16.1.

Note that this plugin will only report the first vulnerable instance
of a Struts2 application.

See also :

http://struts.apache.org/announce.html#a20140424
http://struts.apache.org/release/2.3.x/docs/s2-021.html

Solution :

Upgrade to version 2.3.16.2 or later.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)
CVSS Temporal Score : 4.3
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Denial of Service

Nessus Plugin ID: 73763 ()

Bugtraq ID: 67064
67081

CVE ID: CVE-2014-0112
CVE-2014-0113