Google Chrome < 34.0.1847.131 Multiple Vulnerabilities (Mac OS X)

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote Mac OS X host contains a web browser that is affected by
multiple vulnerabilities.

Description :

The version of Google Chrome installed on the remote Mac OS X host is
a version prior to 34.0.1847.131. It is, therefore, affected by the
following vulnerabilities :

- A buffer overflow error exists related to the included
version of Flash Player. (CVE-2014-0515)

- Type confusion errors exist related to the V8
JavaScript engine and DOM handling. (CVE-2014-1730,
CVE-2014-1731)

- A use-after-free error exists related to speech
recognition processing. (CVE-2014-1732)

- An error exists related to compiling in 'Seccomp-BPF'.
(CVE-2014-1733)

- Various, unspecified errors exist. (CVE-2014-1734)

- Various, unspecified errors exist related to the V8
JavaScript engine. (CVE-2014-1735)

- An integer overflow error exists related to the V8
JavaScript engine. (CVE-2014-1736)

Note that Nessus has not tested for these issues but has instead
relied only on the application's self-reported version number.

See also :

http://www.nessus.org/u?b5291952
http://helpx.adobe.com/security/products/flash-player/apsb14-13.html

Solution :

Upgrade to Google Chrome 34.0.1847.131 or later.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 6.5
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: MacOS X Local Security Checks

Nessus Plugin ID: 73711 ()

Bugtraq ID: 67082
67092

CVE ID: CVE-2014-0515
CVE-2014-1730
CVE-2014-1731
CVE-2014-1732
CVE-2014-1733
CVE-2014-1734
CVE-2014-1735
CVE-2014-1736