VMware Workstation 10.x < 10.0.2 OpenSSL Library Multiple Vulnerabilities (VMSA-2014-0004) (Linux) (Heartbleed)

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote host has a virtualization application that is affected by
multiple vulnerabilities.

Description :

The installed version of VMware Workstation 10.x is prior to 10.0.2.
It is, therefore, reportedly affected by the following vulnerabilities
in the OpenSSL library :

- An error exists related to the implementation of the
Elliptic Curve Digital Signature Algorithm (ECDSA) that
could allow nonce disclosure via the 'FLUSH+RELOAD'
cache side-channel attack. (CVE-2014-0076)

- An out-of-bounds read error, known as the 'Heartbleed
Bug', exists related to handling TLS heartbeat
extensions that could allow an attacker to obtain
sensitive information such as primary key material,
secondary key material and other protected content.
(CVE-2014-0160)

See also :

http://kb.vmware.com/kb/2076225
http://www.nessus.org/u?2a48b929
http://heartbleed.com/

Solution :

Update to VMware Workstation 10.0.2 or later.

Risk factor :

High / CVSS Base Score : 9.4
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:N)
CVSS Temporal Score : 8.2
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: General

Nessus Plugin ID: 73673 ()

Bugtraq ID: 66363
66690

CVE ID: CVE-2014-0076
CVE-2014-0160