Mac OS X Multiple Vulnerabilities (Security Update 2014-002)

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote host is missing a Mac OS X update that fixes several
security issues.

Description :

The remote host is running a version of Mac OS X 10.7, 10.8 or 10.9
that does not have Security Update 2014-002 applied. This update
contains several security-related fixes for the following components :

- CFNetwork HTTPProtocl
- CoreServicesUIAgent
- FontParser
- Heimdal Kerberos
- ImageIO
- Intel Graphics Driver
- IOKit Kernel
- Kernel
- Power Management
- Ruby
- Security - Secure Transport
- Window Server

Note that successful exploitation of the most serious issues could
result in arbitrary code execution.

See also :

http://support.apple.com/kb/HT6207
http://www.securityfocus.com/archive/1/531900/30/0/threaded
http://support.apple.com/kb/HT6246
http://www.securityfocus.com/archive/1/532113/30/0/threaded

Solution :

Either install Security Update 2014-002 or upgrade to OS X Mavericks
10.9.3.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.7
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true