Splunk 6.x < 6.0.3 Multiple OpenSSL Vulnerabilities (Heartbleed)

This script is Copyright (C) 2014-2015 Tenable Network Security, Inc.

Synopsis :

An application on the remote host may be affected by multiple
OpenSSL-related vulnerabilities.

Description :

According to its version number, the remote Splunk install is later
than 6.x but prior to 6.0.3. It is, therefore, affected by multiple
OpenSSL-related vulnerabilities :

- A flaw exists with the OpenSSL version being used by
Splunk with the 'ssl3_take_mac' in 'ssl/s3_both.c'. This
could allow a remote attacker to cause a denial of
service with a specially crafted request.

- A flaw exists with the OpenSSL version being used by
Splunk, where Heartbeat Extension packets are not
properly handled. This could allow a remote attacker
with a specially crafted request to obtain sensitive
information from the process memory. (CVE-2014-0160)

Note that Nessus has not tested for these issues but has instead
relied only on the application's self-reported version number.

See also :


Solution :

Upgrade to Splunk 6.0.3 or later.

Risk factor :

High / CVSS Base Score : 9.4
CVSS Temporal Score : 8.2
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 73575 ()

Bugtraq ID: 64691

CVE ID: CVE-2013-4353