Splunk 6.x < 6.0.3 Multiple OpenSSL Vulnerabilities (including Heartbleed)

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

An application on the remote host may be affected by multiple
OpenSSL-related vulnerabilities.

Description :

According to its version number, the remote Splunk install is later
than 6.x but prior to 6.0.3. It is, therefore, affected by multiple
OpenSSL-related vulnerabilities :

- A flaw exists with the OpenSSL version being used by
Splunk with the 'ssl3_take_mac' in 'ssl/s3_both.c'. This
could allow a remote attacker to cause a denial of
service with a specially crafted request.
(CVE-2013-4353)

- A flaw exists with the OpenSSL version being used by
Splunk, where Heartbeat Extension packets are not
properly handled. This could allow a remote attacker
with a specially crafted request to obtain sensitive
information from the process memory. (CVE-2014-0160)

Note that Nessus has not tested for these issues but has instead
relied only on the application's self-reported version number.

See also :

http://www.splunk.com/view/SP-CAAAMB3
http://docs.splunk.com/Documentation/Splunk/6.0.3/ReleaseNotes/6.0.3

Solution :

Upgrade to Splunk 6.0.3 or later.

Risk factor :

High / CVSS Base Score : 9.4
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:N)
CVSS Temporal Score : 8.2
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 73575 ()

Bugtraq ID: 64691
66690

CVE ID: CVE-2013-4353
CVE-2014-0160