MySQL 5.6.x < 5.6.17 Multiple Vulnerabilities

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote database server is potentially affected by multiple
vulnerabilities.

Description :

The version of MySQL installed on the remote host is version 5.6.x
prior to 5.6.17. It is, therefore, potentially affected by
vulnerabilities in the following components :

- Client
- InnoDB
- Options
- Performance Schema
- RBR

See also :

https://dev.mysql.com/doc/relnotes/mysql/5.6/en/news-5-6-17.html
http://www.nessus.org/u?ef1fc2a6

Solution :

Upgrade to MySQL 5.6.17 or later.

Risk factor :

Medium / CVSS Base Score : 6.0
(CVSS2#AV:N/AC:M/Au:S/C:P/I:P/A:P)
CVSS Temporal Score : 5.2
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: Databases

Nessus Plugin ID: 73574 ()

Bugtraq ID: 66850
66853
66858
66890
66896

CVE ID: CVE-2014-2430
CVE-2014-2431
CVE-2014-2435
CVE-2014-2436
CVE-2014-2440