MySQL 5.6.x < 5.6.16 Multiple Vulnerabilities

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote database server is affected by multiple vulnerabilities.

Description :

The version of MySQL installed on the remote host is version 5.6.x
prior to 5.6.16. It is, therefore, affected by vulnerabilities in the
following components :

- DML
- ENFED
- Federated
- MyISAM
- Optimizer
- Partition
- Privileges
- Replication
- XML

See also :

https://dev.mysql.com/doc/relnotes/mysql/5.6/en/news-5-6-16.html
http://www.nessus.org/u?ef1fc2a6
http://www.nessus.org/u?7de2f8eb

Solution :

Upgrade to MySQL 5.6.16 or later.

Risk factor :

Medium / CVSS Base Score : 6.5
(CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P)
CVSS Temporal Score : 5.7
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false