FortiMail < 4.3.4 / 5.0.0 Multiple XSS

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote host is affected by multiple cross-site scripting
vulnerabilities.

Description :

The remote host is running FortiMail prior to 4.3.4 / 5.0.0. It is,
therefore, affected by multiple cross-site scripting vulnerabilities
due to a failure to sanitize user-supplied input in the web UI.

Specifically, flaws exist in the 'ipmask', 'username', 'address', and
'url' parameters of the '/admin/FEAdmin.html' script as well as the
'SysInterfaceCollection', 'PersonalBlackWhiteList',
'SystemBlackWhiteList', and 'AsBounceverifyKeyCollection' parameters
of the '/admin/FEAdmin.htm' script.

An attacker could potentially exploit this vulnerability to execute
arbitrary JavaScript in the context of the end-user's browser.

See also :

http://www.fortiguard.com/advisory/FG-IR-013-001/

Solution :

Upgrade to 4.3.4 / 5.0.0 or later.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N)
CVSS Temporal Score : 3.6
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: CGI abuses : XSS

Nessus Plugin ID: 73524 ()

Bugtraq ID: 57601

CVE ID: CVE-2013-1471