This script is Copyright (C) 2014 Tenable Network Security, Inc.
The remote web server is affected by a heap buffer overflow
According to the self-reported version in the server response header,
the installed 1.3.x version of nginx is 1.3.15 or higher, or 1.4.x
prior to 1.4.7, or 1.5.x prior to 1.5.12. It is, therefore, affected
by a heap buffer overflow vulnerability.
A flaw exists with the SPDY protocol implementation where user input
is not properly validated. This could allow a remote attacker to cause
a heap-based buffer overflow, causing a denial of service or potential
arbitrary code execution.
Note that Nessus has not tested for this issue but has instead
relied only on the application's self-reported version number.
See also :
Apply the patch manually or upgrade to nginx 1.4.7 / 1.5.12 or later.
Risk factor :
Medium / CVSS Base Score : 5.1
CVSS Temporal Score : 4.4
Public Exploit Available : false