OpenSSL 1.0.1 < 1.0.1g Multiple Vulnerabilities

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote service may be affected by multiple vulnerabilities.

Description :

According to its banner, the remote web server uses a version of
OpenSSL 1.0.1 prior to 1.0.1g. The OpenSSL library is, therefore,
reportedly affected by the following vulnerabilities :

- An error exists related to the implementation of the
Elliptic Curve Digital Signature Algorithm (ECDSA) that
could allow nonce disclosure via the 'FLUSH+RELOAD'
cache side-channel attack. (CVE-2014-0076)

- An out-of-bounds read error, known as the 'Heartbleed
Bug', exists related to handling TLS heartbeat
extensions that could allow an attacker to obtain
sensitive information such as primary key material,
secondary key material and other protected content.
(CVE-2014-0160)

See also :

http://heartbleed.com/
http://eprint.iacr.org/2014/140
http://www.openssl.org/news/vulnerabilities.html#2014-0076
http://www.openssl.org/news/vulnerabilities.html#2014-0160
http://www.mail-archive.com/openssl-announce@openssl.org/msg00131.html
http://www.nessus.org/u?e4229df1

Solution :

Upgrade to OpenSSL 1.0.1g or later.

Alternatively, recompile OpenSSL with the '-DOPENSSL_NO_HEARTBEATS'
flag to disable the vulnerable functionality.

Risk factor :

High / CVSS Base Score : 9.4
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:N)
CVSS Temporal Score : 8.2
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 73404 ()

Bugtraq ID: 66363
66690

CVE ID: CVE-2014-0076
CVE-2014-0160