Better WP Security Plugin for WordPress Multiple XSS

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote web server hosts a web application that is affected by
multiple cross-site scripting vulnerabilities.

Description :

The WordPress Better WP Security Plugin installed on the remote host
is affected by multiple cross-site scripting (XSS) vulnerabilities :

- The application fails to properly sanitize user-supplied
input to the HTTP_USER_AGENT header. (CVE-2012-4263)

- The application fails to properly sanitize user-supplied
input to unspecified server variables. (CVE-2012-4264)

Note that Nessus has not tested for these issues but has instead
relied only on the application's self-reported version number.

See also :

http://www.nessus.org/u?5166c758
http://wordpress.org/plugins/better-wp-security/changelog/

Solution :

Upgrade to version 3.2.5 or later.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N)
CVSS Temporal Score : 4.1
(CVSS2#E:F/RL:U/RC:ND)
Public Exploit Available : true

Family: CGI abuses : XSS

Nessus Plugin ID: 73271 ()

Bugtraq ID: 53480

CVE ID: CVE-2012-4263
CVE-2012-4264