Amazon Linux AMI : 389-ds-base Authentication Vulnerability (ALAS-2014-311)

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote Amazon Linux AMI host is missing a security update.

Description :

It was discovered that the 389 Directory Server did not properly
handle certain SASL-based authentication mechanisms. A user able to
authenticate to the directory using these SASL mechanisms could
connect as any other directory user, including the administrative
Directory Manager account. This could allow them to modify
configuration values, as well as read and write any data the directory
holds. (CVE-2014-0132)

See also :

http://www.nessus.org/u?e98430e3

Solution :

Run 'yum update 389-ds-base' to update your system.

Risk factor :

Medium / CVSS Base Score : 6.5
(CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P)

Family: Amazon Linux Local Security Checks

Nessus Plugin ID: 73230 ()

Bugtraq ID:

CVE ID: CVE-2014-0132